Pretty Urls - Adres strony, czy taki powinien być?

  • 13 Odpowiedzi
  • 758 Wyświetleń

0 użytkowników i 1 Gość przegląda ten wątek.

*

Offline chrumcio

  • ***
  • 34
  • 0
  • AmigaFAN
    • Emulacja i stare gry
  • Domyślny styl: UX
  • Wersja SMF: 2.0.15
Pretty Urls - Adres strony, czy taki powinien być?
« dnia: 14 Luty 2019, 11:34 »
Mam pewne pytanko odnośnie adresu strony. Gdy wchodzę na swoją stronę http://uniret.cba.pl następnie na http://uniret.cba.pl/forum/ i teraz po wejściu w jakiś dział na forum zamienia mi na http://uniret.cba.pl/amiga/
A powinno chyba być http://uniret.cba.pl/forum/amiga/ a nie http://uniret.cba.pl/amiga/
Czy to jest jakiś błąd strony? czy tak może być. Pierwszy raz z czymś takim się spotykam.
« Ostatnia zmiana: 16 Luty 2019, 13:45 wysłana przez CrimeS »

*

Offline js

  • *
  • 413
  • 22
  • Płeć: Mężczyzna
  • Wersja SMF: 2.0.15
Odp: Pretty Urls - Adres strony, czy taki powinien być?
« Odpowiedź #1 dnia: 14 Luty 2019, 12:06 »
Najpierw podaj nazwę modyfikacji, którą użyłeś do zmiany adresów. Oryginalny adres działu to: index.php?board=1.0

*

Offline chrumcio

  • ***
  • 34
  • 0
  • AmigaFAN
    • Emulacja i stare gry
  • Domyślny styl: UX
  • Wersja SMF: 2.0.15
Odp: Pretty Urls - Adres strony, czy taki powinien być?
« Odpowiedź #2 dnia: 14 Luty 2019, 12:11 »
Użyłem 'Pretty URLs 2.1.1"

*

Offline js

  • *
  • 413
  • 22
  • Płeć: Mężczyzna
  • Wersja SMF: 2.0.15
Odp: Pretty Urls - Adres strony, czy taki powinien być?
« Odpowiedź #3 dnia: 14 Luty 2019, 18:18 »
Tak jak napisałeś powinno być. Po włączeniu opcji Enable URL rewriting i opcji w URL rewriting filters i następnie Enable URL rewriting u mnie modyfikacja poprawnie w adresie wskazuje katalog, w którym jest forum.

Sprawdź, czy w Pretty Urls Root masz poprawnie wpisany adres forum z katalogiem forum.

Najpierw sprawdź w Konfiguracja > Ustawienia serwera > Baza danych i ścieżki > Adres forum - jaki masz wpisany dokładnie adres. Z http i www, czy samo http. Potem ustaw to samo w Pretty Urls Root.


*

Offline chrumcio

  • ***
  • 34
  • 0
  • AmigaFAN
    • Emulacja i stare gry
  • Domyślny styl: UX
  • Wersja SMF: 2.0.15
Odp: Pretty Urls - Adres strony, czy taki powinien być?
« Odpowiedź #4 dnia: 19 Luty 2019, 22:25 »
Dzięki za odpowiedź, jutro to sprawdzę bo ostatnio bardzo mało bywałem na chacie.

*

Offline chrumcio

  • ***
  • 34
  • 0
  • AmigaFAN
    • Emulacja i stare gry
  • Domyślny styl: UX
  • Wersja SMF: 2.0.15
Odp: Pretty Urls - Adres strony, czy taki powinien być?
« Odpowiedź #5 dnia: 22 Luty 2019, 12:21 »
Mam wpisane tak
http://uniret.cba.pl czyli mam dopisać forum by to wyglądało tak http://uniret.cba.pl/forum

*

Offline js

  • *
  • 413
  • 22
  • Płeć: Mężczyzna
  • Wersja SMF: 2.0.15
Odp: Pretty Urls - Adres strony, czy taki powinien być?
« Odpowiedź #6 dnia: 22 Luty 2019, 15:54 »
Tak. Wtedy link powinien być prawidłowy.

*

Offline chrumcio

  • ***
  • 34
  • 0
  • AmigaFAN
    • Emulacja i stare gry
  • Domyślny styl: UX
  • Wersja SMF: 2.0.15
Odp: Pretty Urls - Adres strony, czy taki powinien być?
« Odpowiedź #7 dnia: 22 Luty 2019, 16:10 »
Teraz to dziwne rzeczy mi się dzieją na stronie :(
Wystarczy luknąć.
np. http://uniret.cba.pl/forum/forum/ , http://uniret.cba.pl ( nie wyświetla avatra ) , http://uniret.cba.pl/forum/index.php ( gdy z forum przechodzę na stronę główną )

*

Offline js

  • *
  • 413
  • 22
  • Płeć: Mężczyzna
  • Wersja SMF: 2.0.15
Odp: Pretty Urls - Adres strony, czy taki powinien być?
« Odpowiedź #8 dnia: 22 Luty 2019, 16:17 »
Więc usuń to dopisane forum.

W Pretty Urls Root jaki masz poprawny wpisany adres forum?

W Konfiguracja > Ustawienia serwera > Baza danych i ścieżki > Adres forum - jaki masz wpisany dokładny adres?

*

Offline chrumcio

  • ***
  • 34
  • 0
  • AmigaFAN
    • Emulacja i stare gry
  • Domyślny styl: UX
  • Wersja SMF: 2.0.15
Odp: Pretty Urls - Adres strony, czy taki powinien być?
« Odpowiedź #9 dnia: 22 Luty 2019, 16:19 »
W tych dwóch miejscach mam teraz dopisane http://uniret.cba.pl/forum
Edit:// teraz nawet do panelu admina nie mogę wejść.
« Ostatnia zmiana: 22 Luty 2019, 16:21 wysłana przez chrumcio »

*

Offline js

  • *
  • 413
  • 22
  • Płeć: Mężczyzna
  • Wersja SMF: 2.0.15
Odp: Pretty Urls - Adres strony, czy taki powinien być?
« Odpowiedź #10 dnia: 22 Luty 2019, 16:46 »
Dziwna to jest sprawa z SMF na serwerze cba.pl :-\

Zainstalowałeś to forum przez ich gotowy instalator?

Pobierz to narzędzie Repair Settings i wgraj na serwer FTP, tam, gdzie masz główne pliki FORUM. Uruchom to narzędzie przez dopisanie nazwy tego pliku do adresu forum i po wejściu w te ustawienia, odszukaj główny adres forum i wykreśl /forum - skoro tego dopisu wcześniej nie miałeś. I panel admina powinien działać prawidłowo, bo naprawisz adres. Po naprawie adresu i jak wszystko będzie działać usuń ten plik z serwera.

*

Offline chrumcio

  • ***
  • 34
  • 0
  • AmigaFAN
    • Emulacja i stare gry
  • Domyślny styl: UX
  • Wersja SMF: 2.0.15
Odp: Pretty Urls - Adres strony, czy taki powinien być?
« Odpowiedź #11 dnia: 22 Luty 2019, 22:12 »
Nie korzystam z gotowych instalatorów, zobaczę te narzędzie i dam znać.
Edit:// Działa, chwilowo odinstalowałem plugin pretty urls. W sumie i tak wyczytałem na necie że to już nie jest tak skuteczne jak kiedyś.
« Ostatnia zmiana: 22 Luty 2019, 22:27 wysłana przez chrumcio »

*

Offline js

  • *
  • 413
  • 22
  • Płeć: Mężczyzna
  • Wersja SMF: 2.0.15
Odp: Pretty Urls - Adres strony, czy taki powinien być?
« Odpowiedź #12 dnia: 23 Luty 2019, 10:52 »
Możesz skorzystać z wbudowanej opcji dla ustawienia przyjaznych adresów.

Panel admina > Konfiguracja > Właściwości i opcje > Wyświetlaj adresy przyjazne wyszukiwarkom
« Ostatnia zmiana: 23 Luty 2019, 11:02 wysłana przez js »

*

Offline chrumcio

  • ***
  • 34
  • 0
  • AmigaFAN
    • Emulacja i stare gry
  • Domyślny styl: UX
  • Wersja SMF: 2.0.15
Odp: Pretty Urls - Adres strony, czy taki powinien być?
« Odpowiedź #13 dnia: 24 Luty 2019, 14:30 »
Dzięki za pomoc :)