Błędy przy instalacji aktualizacji 2.0.14

  • 10 Odpowiedzi
  • 1853 Wyświetleń

0 użytkowników i 1 Gość przegląda ten wątek.

*

Offline bod22

  • **
  • 20
  • 0
Błędy przy instalacji aktualizacji 2.0.14
« dnia: 30 Wrzesień 2017, 10:08 »
Chciałbym zaktualizować forum z wersji 2.0.13 do 2.0.14. Nigdy nie miałem z tym problemów, ale ta najnowsza wersja wywala mi przy instalacji takie błędy.

https://i.imgur.com/nMlJNGW.jpg
Błędy przy instalacji aktualizacji 2.0.14


https://i.imgur.com/tTVqUJJ.jpg
Błędy przy instalacji aktualizacji 2.0.14


Aktualizację zainstalowałem mimo to, ale kilku użytkowników napisało mi że po niej mają problem z logowaniem, więc ją odinstalowałem.

Błąd wygląda tak

https://i.imgur.com/yKq5CB4.jpg
Błędy przy instalacji aktualizacji 2.0.14

Zastąpiłbym to ręcznie, ale w pliku index.template nie znajduję tego kodu do zastąpienia.


Ktoś wie o co może chodzić?
« Ostatnia zmiana: 30 Wrzesień 2017, 10:46 wysłana przez bod22 »

*

Offline CrimeS

  • *****
  • 1992
  • 273
  • Płeć: Mężczyzna
    • jellyio.com
Odp: Błędy przy instalacji aktualizacji 2.0.14
« Odpowiedź #1 dnia: 30 Wrzesień 2017, 22:16 »
Dodaj ten kod po formularzu logowania w index.template.php
<input type="hidden" name="', $context['session_var'], '" value="', $context['session_id'], '" />

*

Offline bod22

  • **
  • 20
  • 0
Odp: Błędy przy instalacji aktualizacji 2.0.14
« Odpowiedź #2 dnia: 2 Październik 2017, 12:51 »
A jak zajdę kod tego formularza? Pytam bo jestem zielony w temacie kompletny.

Rozumiem, że tam to mam wkleić i potem dokonać aktualizacji?

Z góry dziękuję za pomoc.

*

Offline CrimeS

  • *****
  • 1992
  • 273
  • Płeć: Mężczyzna
    • jellyio.com
Odp: Błędy przy instalacji aktualizacji 2.0.14
« Odpowiedź #3 dnia: 2 Październik 2017, 19:03 »
Pobrałem szablon Reseller i już ma to wklejone standardowo. Jeżeli masz starą wersję to:

Znajdź:
<input type="hidden" name="hash_passwrd" value="" />
Dodaj po:
<input type="hidden" name="', $context['session_var'], '" value="', $context['session_id'], '" />

*

Offline bod22

  • **
  • 20
  • 0
Odp: Błędy przy instalacji aktualizacji 2.0.14
« Odpowiedź #4 dnia: 2 Październik 2017, 22:03 »
Eh, albo robię coś źle, albo nie ogarniam, albo nie wiem co bo u mnie w index.template.php takich rzeczy nie odnajduję...
https://megawrzuta.pl/download/c8793019c0f891075cb711687db0da98.html

Ściągnąłem Reseller ze strony i tam te kody są, a w mojej wersji nie ma.
« Ostatnia zmiana: 2 Październik 2017, 22:35 wysłana przez bod22 »

*

Offline js

  • *
  • 413
  • 22
  • Płeć: Mężczyzna
  • Wersja SMF: 2.0.15
Odp: Błędy przy instalacji aktualizacji 2.0.14
« Odpowiedź #5 dnia: 3 Październik 2017, 09:13 »
Eh, albo robię coś źle, albo nie ogarniam, albo nie wiem co bo u mnie w index.template.php takich rzeczy nie odnajduję...
https://megawrzuta.pl/download/c8793019c0f891075cb711687db0da98.html

Ściągnąłem Reseller ze strony i tam te kody są, a w mojej wersji nie ma.

Zmień motyw forum na Curve, w panelu admina w Zarządzanie stylami w Opcje stylów usuń motyw Reseller, później usuń go z serwera, wgraj ponownie na serwer pobrany motyw Reseller i go zainstaluj.

*

Offline bod22

  • **
  • 20
  • 0
Odp: Błędy przy instalacji aktualizacji 2.0.14
« Odpowiedź #6 dnia: 3 Październik 2017, 19:43 »
Właśnie to wczoraj zrobiłem i wszystko zainstalowało się w tym motywie bez błędów, więc dzięki za naprowadzenie.

*

Offline SMF_2019

  • *
  • 3
  • 0
  • Wersja SMF: 2.0.13
Odp: Błędy przy instalacji aktualizacji 2.0.14
« Odpowiedź #7 dnia: 7 Luty 2019, 22:41 »
cześć mam podobny problem podczas upgrade z wersji 2.0.13 na 2.0.14 mam 3 porażki
dwie w pliku sources/subs.php
i jedna w pliku SSI.php
otworzyłem te pliki przeszukałem i i w pliku subs.php nie ma takich kodów do podmiany...
w pliku SSI.php jest także jedną porażkę mogę naprawić ale tam gdzie brakuje kodu to już nie,
no i nie wiem za bardzo w którym miejscu wkleić ten kod żeby było dobrze...
prośba o pomoc


w załączniku porażka nr 1 w pliku subs.php brakujący kod i kod do zamiany

*

Offline SMF_2019

  • *
  • 3
  • 0
  • Wersja SMF: 2.0.13
Odp: Błędy przy instalacji aktualizacji 2.0.14
« Odpowiedź #8 dnia: 10 Luty 2019, 13:29 »
mógłby ktoś podpowiedzieć co zrobić jeśli nie ma w pliku kodu ,który trzeba zamienić żeby zaktualizować wersję forum z wersji 2.0.13 na 2.0.14 forum jest ogólnie bardzo stare było instalowane na wersji chyba 2.0.1 z 9 lat temu

w którym miejscu dodać ten kod w pliku subs.php (plik w załączniku)

@CrimeS poprawiłem wielkość czcionki
« Ostatnia zmiana: 10 Luty 2019, 14:42 wysłana przez CrimeS »

*

Offline CrimeS

  • *****
  • 1992
  • 273
  • Płeć: Mężczyzna
    • jellyio.com
Odp: Błędy przy instalacji aktualizacji 2.0.14
« Odpowiedź #9 dnia: 10 Luty 2019, 20:50 »
A były wgrywane jakieś modyfikacje? Zawsze można podmienić ten plik z czystej paczki SMF i wykonać aktualizację.

*

Offline SMF_2019

  • *
  • 3
  • 0
  • Wersja SMF: 2.0.13
Odp: Błędy przy instalacji aktualizacji 2.0.14
« Odpowiedź #10 dnia: 10 Luty 2019, 23:05 »
modyfikacji było dużo wgrywane przez 9 lat od wersji chyba 2.0.1 do 2.0.13
wyciagnałem pliki subs.php i ssi.php z paczki instalacyjnej 2.0.13 i porównałem z plikami ,które miałem na serwerze
odnalazłem miejsca w których powinien być podmieniony kod zamieniłem i wgrałem na serwer ( wcześniej zrobiłem kopie )
no i nie zadziałało forum przestało działać więc z powrotem wstawiłem te pliki ,które były wcześniej i forum wróciło


i spróbowałem innej metody brute force zainstalowałem upgrade 2.0.14 mimo ostrzeżenia... zainstalowało się
błędów nie obserwuje na razie sprawdziłem też w opcji konserwacja forum wygląda chyba ok


zainstalowałem upgrade 2.0.15 bez błędów i problemów jak na razie to chyba problem rozwiązany.