Instalowanie skinów / modów niekompatybilnych z naszą wersją.

  • 5 Odpowiedzi
  • 7398 Wyświetleń

0 użytkowników i 1 Gość przegląda ten wątek.

*

Offline prodd.

  • ***
  • 25
  • 6
  • ;>
    • polski support Voyage Century
Trafiłem na fajną metodę (i łatwą ;) ), która pozwoli zainstalować niekompatybilne dodatki do naszego forum.

1. Wchodzimy na zarządzanie skórkami / pakietami.
2. Na końcu adresu URL doklejamy:
;version_emulate=NUMER.WERSJInp.: ;version_emulate=1.1
Spowoduje to emulację wersji w tym wypadku 1.1.

Będzie to wyglądać następująco:
/index.php?action=packages;version_emulate=1.1Np:
http://localhost/index.php?action=packages;version_emulate=1.1

Znalazłem to szukając sposobu na zainstalowanie tinyportalu bez konieczności downgradu skryptu.
Anulowanie emulacji - dodajemy:
;version_emulatedo URLa.

Myślę, że się przyda.

OFC nie róbcie głupot w stylu dodanie jakiegoś wybitnie archaicznego moda (np 1.0.5), bo to już może być problemem. Teoretycznie to piszę, bo nie probowałem, ale IMO od 1.0.5 do 1.1.1 było sporo zmian, także może i się zainstaluje, ale nie będzie sprawne.
« Ostatnia zmiana: 2 Styczeń 2007, 20:38 wysłana przez prodd. »

*

Offline ronin

  • *****
  • 2645
  • 297
  • Płeć: Mężczyzna
    • Poradnia Wellness - nadwaga i niedowaga, dieta herbalife dla każdego
Odp: Instalowanie skinów / modów niekompatybilnych z naszą wersją.
« Odpowiedź #1 dnia: 1 Styczeń 2007, 13:51 »
hmm moze to i dobre ale beda same problemy

*

Offline prodd.

  • ***
  • 25
  • 6
  • ;>
    • polski support Voyage Century
Odp: Instalowanie skinów / modów niekompatybilnych z naszą wersją.
« Odpowiedź #2 dnia: 1 Styczeń 2007, 14:22 »
A to czemu?  ;)

Dzięki temu zainstalowałem sobie np TinyPortal i Visual warnings mod.

W sumie zmiany między 1.1 a 1.1.1 są minimalne, ale już przez tą głupią jedynkę na końcu połowa modów jest niekompatybilna.

*

Offline defc0n

  • ****
  • 855
  • 67
Odp: Instalowanie skinów / modów niekompatybilnych z naszą wersją.
« Odpowiedź #3 dnia: 6 Styczeń 2007, 20:45 »
Dobre jesli user wie co robi.

*

Offline neox

  • **
  • 20
  • 0
Odp: Instalowanie skinów / modów niekompatybilnych z naszą wersją.
« Odpowiedź #4 dnia: 21 Grudzień 2007, 12:11 »
nie działa na 1.1.4  :P
Serdecznie pozdrawiam
www.zbuntowana.warszawa.pl

*

Offline tommass

  • ****
  • 36
  • 0
  • Płeć: Mężczyzna
    • MilSim.pl
Odp: Instalowanie skinów / modów niekompatybilnych z naszą wersją.
« Odpowiedź #5 dnia: 4 Styczeń 2008, 01:52 »
Hmm... Jak instalowałem polskiego sboxa, to odkryłem coś takiego:
W paczce z modem jest plik package-info.xml
Edytujemy i odnajdujemy:
<install for="1.1 RC3, 1.1, 1.1.1, 1.1.2, 1.1.3,">
dodajemy na końcu 1.1.4 żeby wyglądało tak:
<install for="1.1 RC3, 1.1, 1.1.1, 1.1.2, 1.1.3, 1.1.4">
I śmiga!!  ;D

Z zastrzeżeniem że nie będzie to zbyt stary mod.
Ten mod był przeze mnie zainstalowany w wersji 1.1.3 i działał po upgreade do 1.1.4. Tylko że świeża instalka 1.1.4 go nie brała. Logiczne było zatem że to można jakoś "naprawić"

pozdrawiam