Problem z SSL i Chrome
http://hosting.pro-linuxpl.com/

Problem z SSL i Chrome

  • 9 Odpowiedzi
  • 335 Wyświetleń

0 użytkowników i 1 Gość przegląda ten wątek.

*

Offline bod22

  • **
  • 18
  • 0
Problem z SSL i Chrome
« dnia: 2 Czerwiec 2018, 08:45 »
Mam duży problem z instalacją  SSL na swoim forum. Od wczoraj się z tym męczę i nic nie działa i już nie wiem co robić.

Certyfikat działa, w sensie mam go zainstalowanego dobrze, działa na głównej z Wordpress. Problem jest z forum tylko. Wrzuciłem na serwer repair_settings i podmieniłem http na https. I teraz tak moje forum inaczej zachowuje się w przeglądarce Firefox, a inaczej w Chrome.

W Firefox wszystko działa, tylko nie mam zielonej kłódki, natomiast w Chrome mam informację że jest strona zabezpieczona, a czasem że nie, ale nie mogę klikać w wiele elementów, chodzi o przyciski, jak zaloguj w logo, czy "plusy", które w moim motywie są potrzebne do pisania odpowiedzi. Na telefonie w Chrome również to nie działa plus rozwijane menu. Co może być nie tak?

Proszę o pomoc, bo aktualnie forum nie działa dla wielu użytkowników w takiej formie.
Adres: strefapsx.pl/forum/
Motyw z jakiego korzystam to Reseller i zakładam, że to po jego stronie może stać problem. Po prostu przy użyciu https nie działają te nawigacyjne przyciski. Można to jakoś obejść? Dzieje się tak tylko w Chrome, na Firefox jest ok.
« Ostatnia zmiana: 2 Czerwiec 2018, 09:07 wysłana przez bod22 »

*

Offline CrimeS

  • *****
  • 1957
  • 262
  • Płeć: Mężczyzna
    • studiocrimes.com
Odp: Problem z SSL i Chrome
« Odpowiedź #1 dnia: 2 Czerwiec 2018, 09:43 »
Wszystkie ścieżki w repair_settings są podmienione?

Szukając problemu, zainteresował mnie fakt że wszystkie przyciski które używają data-target poprzez jQuery nie działają (wymienione przyciski). Konsola przeglądarki zwraca błędy, które informują o tym że Chrome zablokowało ładowanie bibliotek jQuery. Firefox może niekoniecznie blokować je.

W index.template.php w plikach Twojego szablonu, znajdź poniższy link:
http://ajax.googleapis.com/ajax/libs/jquery/2.1.1/jquery.min.js
Zamień na:
//ajax.googleapis.com/ajax/libs/jquery/2.1.1/jquery.min.js
Zrób tak samo w z innymi linkami z załączonego obrazka.

*

Offline bod22

  • **
  • 18
  • 0
Odp: Problem z SSL i Chrome
« Odpowiedź #2 dnia: 2 Czerwiec 2018, 11:36 »
To było to, teraz jest i kłódka i wszystko działa w Chrome i Firefox. Dzięki wielkie bo już myślałem, że będę musiał motyw zmieniać.

Chciałbym zmienić jeszcze te pozostałe linki, ale zawsze mam z tym problem, jak mogę popatrzeć gdzie ich szukać? Bo w index.template ich nie ma.

*

Offline CrimeS

  • *****
  • 1957
  • 262
  • Płeć: Mężczyzna
    • studiocrimes.com
Odp: Problem z SSL i Chrome
« Odpowiedź #3 dnia: 2 Czerwiec 2018, 12:24 »
Czy były jakieś czcionki dodawane niestandardowo, czy ona z szablonu jest? Mogę potem sprawdzić gdzie to siedzi :)

*

Offline bod22

  • **
  • 18
  • 0
Odp: Problem z SSL i Chrome
« Odpowiedź #4 dnia: 2 Czerwiec 2018, 12:31 »
Dodałem jedną, ale to nie ta o którą krzyczą te komunikaty, tą wrzuciłem zresztą na serwer. Open Sans bo chyba o nią się rozchodzi jest domyślną czcionką w Reseller. Jakbyś mógł rzucić okiem w wolnej chwili, będę wdzięczy. Nie spieszy się bo cała reszta hula aż miło. Niepotrzebnie pół dnia na dostosowywanie innego motywu straciłem.

*

Offline CrimeS

  • *****
  • 1957
  • 262
  • Płeć: Mężczyzna
    • studiocrimes.com
Odp: Problem z SSL i Chrome
« Odpowiedź #5 dnia: 2 Czerwiec 2018, 21:49 »
Szczerze mówiąc to nie wiem skąd ta czcionka się ładuje. Jeżeli po wgraniu czystego szablonu będzie dalej to samo, to raczej trzeba autora szablonu się zapytać. Albo zmienić testowo na inny szablon i zobaczyć czy to dalej się pojawia.

*

Offline Adrian

  • ****
  • 5459
  • 713
  • Płeć: Mężczyzna
  • Smile, tomorrow will be worse...
Odp: Problem z SSL i Chrome
« Odpowiedź #6 dnia: 2 Czerwiec 2018, 23:43 »
Problem dalej występuje? Przeglądając stronę w najnowszym Google Chrome wszystko według mnie działa w tej chwili prawidłowo na SSL.

Pobierz z załącznika plik bootstrap.zip, rozpakuj go i otrzymany plik bootstrap.css wrzuć do ./Themes/Reseller/css podmieniając istniejący plik.
« Ostatnia zmiana: 2 Czerwiec 2018, 23:47 wysłana przez Adrian »

*

Offline bod22

  • **
  • 18
  • 0
Odp: Problem z SSL i Chrome
« Odpowiedź #7 dnia: 3 Czerwiec 2018, 10:35 »
Dziękuję Panowie, udało się wszystko ogarnąć. Podmieniłem plik i zniknął problem z czcionką. Jeden błąd sam wyeliminowałem, zostało coś jeszcze, ale to już mi chyba nie przeszkadza w niczym. 

*

Offline Adrian

  • ****
  • 5459
  • 713
  • Płeć: Mężczyzna
  • Smile, tomorrow will be worse...
Odp: Problem z SSL i Chrome
« Odpowiedź #8 dnia: 3 Czerwiec 2018, 11:45 »
Co pozostało? Pisz, może uda się jakoś pomóc :)

*

Offline bod22

  • **
  • 18
  • 0
Odp: Problem z SSL i Chrome
« Odpowiedź #9 dnia: 3 Czerwiec 2018, 15:46 »
O, ten ostatni też się rozwiązał, przynajmniej Chrome nic nie pokazuje, więc jest już wszystko, przynajmniej w tym temacie. ;)