http://hosting.pro-linuxpl.com/

Przeniesienie tematu - niepoprawny BBcode w linku przekierowującym.

  • 9 Odpowiedzi
  • 806 Wyświetleń

0 użytkowników i 2 Gości przegląda ten wątek.

*

Offline pretor

  • ****
  • 1496
  • 72
    • VW Club Polska
  • Wersja SMF: 2.0.15
Witam.
Już jakiś czas temu zauważyłem, że przenosząc jakikolwiek temat do innego działu, w poście kierującym znajduje się nieaktywny link do tego tematu.
Zamiast  [url] link [/url]  pojawia się  [iurl] link [/iurl]

Ten wątek został przeniesiony do [url=http://vw-clubpolska.pl/index.php?board=32.0]<font color="#313846">Hyde-Park</font>[/url].

[iurl]http://vw-clubpolska.pl/index.php?topic=4326.0[/iurl]
W pierwszym linku pojawia się kawałek kodu html, tak chyba nie powinno być? Ale tek kawałek html, bierze się chyba z dodatkowych kolorów działów które sam sobie wpisałem. Więc chyba wystarczy go usunąć z nazwy i będzie po problemie.

Jak i gdzie można to naprawić ?
Pytania odnośnie działania SMF, zadaje się na forum w odpowiednim dla nich dziale ;)
VW Club PolskaDzień dobry K-Koźle

*

Offline pretor

  • ****
  • 1496
  • 72
    • VW Club Polska
  • Wersja SMF: 2.0.15
Cytat: pretor link=topic=12751
Ten wątek został przeniesiony do [url=http://vw-clubpolska.pl/index.php?board=32.0]<font color="#313846">Hyde-Park</font>[/url].W pierwszym linku pojawia się kawałek kodu html, tak chyba nie powinno być? Ale tek kawałek html, bierze się chyba z dodatkowych kolorów działów które sam sobie wpisałem. Więc chyba wystarczy go usunąć z nazwy i będzie po problemie.

Jak i gdzie można to naprawić ?
Tutaj tak jak myślałem winnym okazał się kod HTML wpisany w nazwie działu - zostało to naprawiane.

Cytat: pretor link=topic=12751
Już jakiś czas temu zauważyłem, że przenosząc jakikolwiek temat do innego działu, w poście kierującym znajduje się nieaktywny link do tego tematu.
Zamiast  [url] link [/url]  pojawia się  [iurl] link [/iurl]

Ten wątek został przeniesiony do [iurl=http://vw-clubpolska.pl/index.php?board=32.0]Hyde-Park[/iurl]
Tego problemu z wadliwym BBcode w linku  [iurl] link [/iurl] , nie udało mi się rozwiązać i prosiłbym o  podpowiedź gdzie szukać przyczyny takiego błędu ;)




Pytania odnośnie działania SMF, zadaje się na forum w odpowiednim dla nich dziale ;)
VW Club PolskaDzień dobry K-Koźle

*

Offline pretor

  • ****
  • 1496
  • 72
    • VW Club Polska
  • Wersja SMF: 2.0.15
Odp: Przeniesienie tematu - niepoprawny BBcode w linku przekierowującym.
« Odpowiedź #2 dnia: 14 Październik 2018, 10:51 »
Podbijam temat, bo problem występuje dalej i nie wiem jak sobie z nim poradzić.

Link do wspomnianego wyżej przeniesienia tematu: http://vw-clubpolska.pl/index.php/topic,5921.html

Wygląd linku przekierowującego:
[iurl]http://vw-clubpolska.pl/index.php?topic=5920.0[/iurl]
« Ostatnia zmiana: 14 Październik 2018, 10:53 wysłana przez pretor »
Pytania odnośnie działania SMF, zadaje się na forum w odpowiednim dla nich dziale ;)
VW Club PolskaDzień dobry K-Koźle

*

Offline Nolt

  • *****
  • 3258
  • 246
  • Płeć: Mężczyzna
    • Wizzi
  • Domyślny styl: ID
  • Wersja SMF: 2.0.15
Odp: Przeniesienie tematu - niepoprawny BBcode w linku przekierowującym.
« Odpowiedź #3 dnia: 20 Październik 2018, 16:51 »
Sprawdź mody odpowiadające za BBC, domyślnie SMF nie stosuje tego typu znaczników.
www.wizzi.pl - polskie wsparcie TinyPortal i MaNGOS
Moje style dla SMF 2

SMF.PL FAQ
nie odpowiadam na żadne PW, więc ich nie wysyłajcie chyba że zostaniecie o to poproszeni

*

Offline pretor

  • ****
  • 1496
  • 72
    • VW Club Polska
  • Wersja SMF: 2.0.15
Odp: Przeniesienie tematu - niepoprawny BBcode w linku przekierowującym.
« Odpowiedź #4 dnia: 20 Październik 2018, 18:56 »
Mam tylko jeden, który bezpośrednio odnosi się do BBcode: BBC [you] Tag wersja 1.3 instalowany w kwietniu 2015 roku.

Jest już nowsza wersja 2.0, wgrałem po usunięciu starszej wersji 1.3 ale przy próbie przeniesieniu tematu - błąd dalej występuje. Więc to nie ten mod.

Nie widzę u mnie innych modów, które były by związane z BBcode.
Sprawdziłem też na drugim forum i mam ten sam błąd a tam o połowę mniej modyfikacji.
« Ostatnia zmiana: 20 Październik 2018, 18:59 wysłana przez pretor »
Pytania odnośnie działania SMF, zadaje się na forum w odpowiednim dla nich dziale ;)
VW Club PolskaDzień dobry K-Koźle

*

Offline Nolt

  • *****
  • 3258
  • 246
  • Płeć: Mężczyzna
    • Wizzi
  • Domyślny styl: ID
  • Wersja SMF: 2.0.15
Odp: Przeniesienie tematu - niepoprawny BBcode w linku przekierowującym.
« Odpowiedź #5 dnia: 20 Październik 2018, 21:53 »
Sprawdzałeś na drugim forum, czy na nim masz też tą modyfikację? Próbowałeś usunąć ją całkowicie?
www.wizzi.pl - polskie wsparcie TinyPortal i MaNGOS
Moje style dla SMF 2

SMF.PL FAQ
nie odpowiadam na żadne PW, więc ich nie wysyłajcie chyba że zostaniecie o to poproszeni

*

Offline Adrian

  • ****
  • 5464
  • 714
  • Płeć: Mężczyzna
  • Smile, tomorrow will be worse...
Odp: Przeniesienie tematu - niepoprawny BBcode w linku przekierowującym.
« Odpowiedź #6 dnia: 20 Październik 2018, 23:03 »
Problemem jest pojawianie się iurl zamiast url? Tak ma być, iurl stosowany jest w linkach wewnętrznych na forum..

*

Offline pretor

  • ****
  • 1496
  • 72
    • VW Club Polska
  • Wersja SMF: 2.0.15
Odp: Przeniesienie tematu - niepoprawny BBcode w linku przekierowującym.
« Odpowiedź #7 dnia: 20 Październik 2018, 23:20 »
@Nolt, sprawdzałem i na drugim forum jest dokładnie to samo a i modyfikacji mam tam dużo mniej.
@Adrian, tutaj na forum SMF.pl ten problem nie występuje, przykład: http://www.smf.pl/index.php/topic,12635.0.html

Jestem też bardzo ciekawy czy jeszcze ktoś z administratorów skryptu SMF, ma podobne problemy przy przenoszeniu tematów?
Pytania odnośnie działania SMF, zadaje się na forum w odpowiednim dla nich dziale ;)
VW Club PolskaDzień dobry K-Koźle

*

Offline Adrian

  • ****
  • 5464
  • 714
  • Płeć: Mężczyzna
  • Smile, tomorrow will be worse...
Odp: Przeniesienie tematu - niepoprawny BBcode w linku przekierowującym.
« Odpowiedź #8 dnia: 21 Październik 2018, 09:14 »
Skąd wiesz że nie występuje? Na pewno również jest użyty w wiadomości IURL zamiast URL.

Sprawdź czy masz aktywny BBCode IURL w ustawieniach Centrum administracji » Wiadomości i wątki » Bulletin Board Code

Na przykład z innego forum:
https://i.imgur.com/HpzxpaJ.png
Przeniesienie tematu - niepoprawny BBcode w linku przekierowującym.
« Ostatnia zmiana: 21 Październik 2018, 09:17 wysłana przez Adrian »

*

Offline pretor

  • ****
  • 1496
  • 72
    • VW Club Polska
  • Wersja SMF: 2.0.15
Odp: Przeniesienie tematu - niepoprawny BBcode w linku przekierowującym.
« Odpowiedź #9 dnia: 21 Październik 2018, 11:45 »
No i chyba mamy 'winnego" tego problemu ::)
W ustawieniach » Wiadomości i wątki » Bulletin Board Code, nie było zaznaczonej opcji "iurl".
Nie wiedziałem do czego ten "kod" może służyć, więc miałem go od dość dawna wyłączonego na obydwóch forach.

Po zaznaczeniu opcji "iurl", linki w info o przenoszonych tematach są aktywne i działają tak jak powinny działać  :)
Na screenie w załączniku, wygląd ustawień BBcode z niezaznaczoną opcją "iurl" i występującym problemem.

Dziękuję za naprowadzenie mnie na właściwy trop
Pytania odnośnie działania SMF, zadaje się na forum w odpowiednim dla nich dziale ;)
VW Club PolskaDzień dobry K-Koźle