http://hosting.pro-linuxpl.com/

Problem z miesiącem Styczeń.

  • 14 Odpowiedzi
  • 2401 Wyświetleń

0 użytkowników i 1 Gość przegląda ten wątek.

*

Offline luk19952

  • **
  • 18
  • 0
  • Wersja SMF: 2.0.13
Problem z miesiącem Styczeń.
« dnia: 8 Styczeń 2017, 22:35 »
Witam.
Mam następujący problem ogólnie kodowanie znaków jest poprawne ale mam problem z miesiącem Styczeń.
S zastępuje się jakimś dziwnym znaczkiem  ſ
Screen w załączniku.

*

Offline Nolt

  • *****
  • 3212
  • 240
  • Płeć: Mężczyzna
    • Wizzi
  • Domyślny styl: ID
  • Wersja SMF: 2.0.13
Odp: Problem z miesiącem Styczeń.
« Odpowiedź #1 dnia: 10 Styczeń 2017, 23:25 »
Wersja 2.0.2? Próbowałeś zaktualizować tłumaczenie?
www.wizzi.pl - polskie wsparcie TinyPortal i MaNGOS
Moje style dla SMF 2

SMF.PL FAQ
nie odpowiadam na żadne PW, więc ich nie wysyłajcie chyba że zostaniecie o to poproszeni

*

Offline luk19952

  • **
  • 18
  • 0
  • Wersja SMF: 2.0.13
Odp: Problem z miesiącem Styczeń.
« Odpowiedź #2 dnia: 11 Styczeń 2017, 02:08 »
Próbowałem, bez zmian. Wersja to 2.0.5 (zmieniłem już w profilu na forum tutaj)

*

Offline pretor

  • ****
  • 1399
  • 65
    • VW Club Polska
  • Wersja SMF: 2.0.14
Odp: Problem z miesiącem Styczeń.
« Odpowiedź #3 dnia: 11 Styczeń 2017, 10:29 »
Próbowałem, bez zmian. Wersja to 2.0.5 (zmieniłem już w profilu na forum tutaj)
Mamy od początku tego roku wersję 2.0.13, to na wypadek gdybyś nie zauważył ;)

Zaktualizuj swoją wersje 2.0.5 forum do najnowszej dostępnej 2.0.13 i sprawdź czy problem dalej występuje.
Pytania odnośnie działania SMF, zadaje się na forum w odpowiednim dla nich dziale ;)
VW Club PolskaDzień dobry K-Koźle

*

Offline luk19952

  • **
  • 18
  • 0
  • Wersja SMF: 2.0.13
Odp: Problem z miesiącem Styczeń.
« Odpowiedź #4 dnia: 17 Luty 2017, 01:51 »
Zaktualizowałem forum do wersji 2.0.13 i nadal ten sam problem. Link do przykładowego tematu, ostatni post. Link.
« Ostatnia zmiana: 17 Luty 2017, 01:55 wysłana przez luk19952 »

*

Offline Nolt

  • *****
  • 3212
  • 240
  • Płeć: Mężczyzna
    • Wizzi
  • Domyślny styl: ID
  • Wersja SMF: 2.0.13
Odp: Problem z miesiącem Styczeń.
« Odpowiedź #5 dnia: 17 Luty 2017, 18:22 »
Sprawdź:
 - czy problem występuje na stylu domyślnym?
 - jakie kodowanie ma baza oraz metoda porównań znaków w mysql
 - jakiego kodowania używasz na forum?
www.wizzi.pl - polskie wsparcie TinyPortal i MaNGOS
Moje style dla SMF 2

SMF.PL FAQ
nie odpowiadam na żadne PW, więc ich nie wysyłajcie chyba że zostaniecie o to poproszeni

*

Offline luk19952

  • **
  • 18
  • 0
  • Wersja SMF: 2.0.13
Odp: Problem z miesiącem Styczeń.
« Odpowiedź #6 dnia: 17 Luty 2017, 19:03 »
Problem występuje nawet na stylu domyślnym.
Kodowanie bazy danych utf8, metoda porównywania napisów utf8_polish_ci.
Na forum używam kodowania utf8


Dziwna sytuacja ponieważ te dziwne "s" występuje tylko w profilu użytkownika jak ktoś się zarejestrował w styczniu no i w postach.
W kalendarzy normalnie miesiąc styczeń się wyświetla. Próbowałem już przeinstalowywać spolszczenia ale nic to nie daje.
« Ostatnia zmiana: 17 Luty 2017, 19:41 wysłana przez luk19952 »

*

Offline Nolt

  • *****
  • 3212
  • 240
  • Płeć: Mężczyzna
    • Wizzi
  • Domyślny styl: ID
  • Wersja SMF: 2.0.13
Odp: Problem z miesiącem Styczeń.
« Odpowiedź #7 dnia: 18 Luty 2017, 19:27 »
Dlaczego używasz metody porównań utf8_polish_ci? Od zawsze sugerowaliśmy korzystać z utf8_general_ci. Może, masz jakąś modyfikację ingerującą w profil użytkownika? Czy próbowałeś zainstalować czyste forum i zaimportować istniejącą bazę do czystej instalki?
www.wizzi.pl - polskie wsparcie TinyPortal i MaNGOS
Moje style dla SMF 2

SMF.PL FAQ
nie odpowiadam na żadne PW, więc ich nie wysyłajcie chyba że zostaniecie o to poproszeni

*

Offline luk19952

  • **
  • 18
  • 0
  • Wersja SMF: 2.0.13
Odp: Problem z miesiącem Styczeń.
« Odpowiedź #8 dnia: 19 Luty 2017, 00:02 »
Dziwne zainstalowałem na testowym forum czystą paczkę z metodą porównań utf8_general_ci i problem taki sam. Sam już nie wiem dlaczego się tak dzieje.

*

Offline Nolt

  • *****
  • 3212
  • 240
  • Płeć: Mężczyzna
    • Wizzi
  • Domyślny styl: ID
  • Wersja SMF: 2.0.13
Odp: Problem z miesiącem Styczeń.
« Odpowiedź #9 dnia: 24 Luty 2017, 12:24 »
Spróbuj w takim razie jeszcze zainstalować całkowicie puste forum bez importowania swojej bazy. Gdyby paczka była uszkodzona, wszyscy mielibyśmy ten sam problem. Tak z ciekawości, gdzie masz swoje forum?
www.wizzi.pl - polskie wsparcie TinyPortal i MaNGOS
Moje style dla SMF 2

SMF.PL FAQ
nie odpowiadam na żadne PW, więc ich nie wysyłajcie chyba że zostaniecie o to poproszeni

*

Offline luk19952

  • **
  • 18
  • 0
  • Wersja SMF: 2.0.13
Odp: Problem z miesiącem Styczeń.
« Odpowiedź #10 dnia: 24 Luty 2017, 13:06 »
No właśnie instalowałem czystą paczkę bez importowania swojej bazy danych i to samo, widocznie coś z hostingiem.
Forum trzymam na serwerze kylos.pl

*

Offline Nolt

  • *****
  • 3212
  • 240
  • Płeć: Mężczyzna
    • Wizzi
  • Domyślny styl: ID
  • Wersja SMF: 2.0.13
Odp: Problem z miesiącem Styczeń.
« Odpowiedź #11 dnia: 26 Luty 2017, 13:08 »
W takim razie porozmawiaj z usługodawcą, zgłoś im problem.
www.wizzi.pl - polskie wsparcie TinyPortal i MaNGOS
Moje style dla SMF 2

SMF.PL FAQ
nie odpowiadam na żadne PW, więc ich nie wysyłajcie chyba że zostaniecie o to poproszeni

*

Offline Adrian

  • ****
  • 5445
  • 712
  • Płeć: Mężczyzna
  • Smile, tomorrow will be worse...
Odp: Problem z miesiącem Styczeń.
« Odpowiedź #12 dnia: 27 Luty 2017, 23:10 »
Centrum administracji » Właściwości i Opcje » Opcje

Napisz jaki masz podany Domyślny format czasu

/edit:

Chociaż faktycznie wygląda na to że serwer może źle współpracować z funkcją wyświetlającą czas na forum.
« Ostatnia zmiana: 27 Luty 2017, 23:28 wysłana przez Adrian »

*

Offline luk19952

  • **
  • 18
  • 0
  • Wersja SMF: 2.0.13
Odp: Problem z miesiącem Styczeń.
« Odpowiedź #13 dnia: 28 Luty 2017, 00:47 »
Centrum administracji » Właściwości i Opcje » Opcje

Napisz jaki masz podany Domyślny format czasu



Domyślny format czasu mam taki. %B %d, %Y, %H:%M:%S

*

Offline luk19952

  • **
  • 18
  • 0
  • Wersja SMF: 2.0.13
Odp: Problem z miesiącem Styczeń.
« Odpowiedź #14 dnia: 18 Kwiecień 2017, 00:38 »
Wszystko wróciło do normy. Nie miałem czasu pisać do hostingu ale widać coś ruszali. Ważne, że teraz jest wszystko ok. Dzięki za pomoc. :)